Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.

Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. (http://xbmc.ru/forum/index.php)
-   Подсказки, описания и FAQ по XBMC (http://xbmc.ru/forum/forumdisplay.php?f=3)
-   -   Kodi не отображает фильмы (http://xbmc.ru/forum/showthread.php?t=21588)

Lapochkin 07.10.2020 14:32

Kodi не отображает фильмы
 
Вложений: 1
Приветствую всех участников!
Дано: Клиент01: ПК на базе x86, Windows 10 x64, Kodi 18.8; Клиент02: ПК на базе x86, Windows 10 x64, Kodi 18.8; Клиент03: ПК на базе x86, LibreElec.
Ещё 1 комп на Windows 7 x64 с установленным MySQL Server 6.0.
Так же есть NAS с расшаренными по SMB папками с фильмами. Имена фильмов имеют вид "«V» значит Вендетта (2005) (V for Vendetta).avi", т.е. русское название, пробел, год в скобках, пробел, английское название в скобках - все данные взяты с Кинопоиска. Скрапится это все без проблем, Kodi показывает всю информацию о фильме, когда БД настроена локально.
Когда настраиваю хранение базы в SQL - база в нём создаётся, даже разрастается до нескольких мегабайт. При этом позиции просмотра между клиентами синхронизируются, видео, которые просмотрены, отображаются таковыми на всех клиентах.
Папка Thumbnails перенесена в шару на том же НАСе, права на неё полные, при запуске сканирования в папке Thumbnails появляются папка, но общий размер гораздо меньше, чем при локальном хранении.
Ниже листинг файла advancedsettings.xml:
<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>10.10.1.254</host>
<port>3306</port>
<user>root</user>
<pass>123</pass>
</videodatabase>
<pathsubstitution>
<substitute>
<from>special://masterprofile/sources.xml</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/sources.xml</to>
</substitute>
<substitute>
<from>special://masterprofile/mediasources.xml</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/mediasources.xml</to>
</substitute>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/Thumbnails/</to>
</substitute>
</pathsubstitution>
</advancedsettings>

Проблема в том, что Kodi не отображает видео в галерее, там пусто (см. скриншот Screenshot_1.png). Подскажите, что с этим можно поделать, как решить проблему?

-=Vd=- 07.10.2020 15:07

Лог скиньте (желательно дебаг режим) от того Коди, в котором не отображаются фильмы.

ЗЫ: Папка Thumbnails у каждого клиента должна быть своя, они не синхронизируемые.

Lapochkin 07.10.2020 15:27

Вложений: 1
Цитата:

Сообщение от -=Vd=- (Сообщение 150986)
Лог скиньте (желательно дебаг режим) от того Коди, в котором не отображаются фильмы.

ЗЫ: Папка Thumbnails у каждого клиента должна быть своя, они не синхронизируемые.

Лог во вложении.
В том и дело, что начинаю с первого клиента: запустил, сформировалась локальная БД. Выключил, подсунул xml с настройками, запустил - результат описал - фильмов в галерее нет, как файлы Kodi фильмы видит.

-=Vd=- 07.10.2020 16:49

Цитата:

Сообщение от Lapochkin (Сообщение 150987)
Лог во вложении.
В том и дело, что начинаю с первого клиента: запустил, сформировалась локальная БД. Выключил, подсунул xml с настройками, запустил - результат описал - фильмов в галерее нет, как файлы Kodi фильмы видит.

Зачем формировать локальную БД? Нужно с сразу с MySQL запускать и делать обновление медиатеки.

У вас с 301й строки ошибки доступа к БД.

Lapochkin 07.10.2020 16:55

Цитата:

Сообщение от -=Vd=- (Сообщение 150988)
Зачем формировать локальную БД? Нужно с сразу с MySQL запускать и делать обновление медиатеки.

У вас с 301й строки ошибки доступа к БД.

Я к тому, что локально БД формируется без проблем...
Да, увидел кучу ошибок в логе. ПодскАжите, с чем связаны ошибки и как устранить?

-=Vd=- 07.10.2020 17:03

Цитата:

Сообщение от Lapochkin (Сообщение 150990)
Я к тому, что локально БД формируется без проблем...
Да, увидел кучу ошибок в логе. ПодскАжите, с чем связаны ошибки и как устранить?

Вероятно MySQL недонастроен как следует. Права доступа смотрите. Мне кажется использовать учётную запись root неправильно. Смотрите здесь всё описано.

Lapochkin 08.10.2020 01:09

Цитата:

Сообщение от -=Vd=- (Сообщение 150991)
Вероятно MySQL недонастроен как следует. Права доступа смотрите. Мне кажется использовать учётную запись root неправильно. Смотрите здесь всё описано.

Благодарю автора данного ответа - получилось синхронизировать библиотеки. В ближайшее время подробно изложу, что именно было сделано!


Текущее время: 20:37. Часовой пояс GMT +3.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.