Показать сообщение отдельно
Старый 30.01.2011, 16:57   #8
askain
Junior Member
 
Регистрация: 20.11.2010
Сообщений: 2
По умолчанию Advanced Launcher проблема в режиме portable

Начал недавно копаться в XBMC, так что сильно не пинайте.
Настроил snes9x через Advanced Launcher (XBMC последний, запускаю в режиме portable). Все работало нормально, но когда перенес на другой комп, эмулятор перестал работать.
Начал копаться, обнаружил, что в Launchers.xml прописан точный путь, например:
<application>e:\xbmc\emul\snes9x\snes9x.exe</application>
Перелопатил инет, как сделать непривязанный путь, нашел
special://xbmc
Прописываю
<application>special://xbmc/emul/snes9x/snes9x.exe</application>
а при запуске получаю ошибку

Со слешами эксперементировал, результат один.
Причем прописанные таким образом Thumbs и Fanart нормально работают (т.е. иконки ромов xbmc отображает нормально).
Помогите решить проблему и подскажите где искать косяк: в AL или в самом XBMC???

Добавлено 17:42
Вроде проблема не в плагине.
Поставил RomCollection Browser, таже беда, говорит такой папки нет...

в xbmc.log есть строчка
17:42:26 T:868 M:152870912 NOTICE: RCB_INFO: cmd: call "special://home/emul/snes9x/snes9x.exe" "E:\USB\XBMC\portable_data\emul\snes9x\Roms\Do nkey Kong Country (U) (V1.2) [!].smc"

На сколько я понимаю, что касаемо ROMa, путь переделывается, т.е. special://home, заменяется на E:\USB\XBMC\portable_data
а вот путь самого эмулятора почему-то не изменяется :-( т.е. то, что находится между <application> </application> не переделывается
askain вне форума   Ответить с цитированием