Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Помощь и поддержка > Помощь по плагинам

Ответ
 
Опции темы Опции просмотра
Старый 29.05.2010, 08:57   #1
Rock82
Member
 
Регистрация: 28.05.2010
Сообщений: 76
По умолчанию Не запускаются плагины в win7(x64)

Помогите пожалуйста, не могу запустить svn installer в xbmc-r28256-trunk
на XP всё работает, а вот на win7(x64) ни в какую в логе написано ImportError: No module named installerAPI
Rock82 вне форума   Ответить с цитированием
   
Старый 29.05.2010, 16:55   #2
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,389
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

No module named installerAPI -в смысле нет такого модуля.
Примерно так XBMC\plugins\programs\SVN Repo Installer\installer API\
В этой папке должны быть:
__init__.py
xbmcplugin_actions.py
xbmcplugin_downloader.py
xbmcplugin_info.py
xbmcplugin_lib.py
xbmcplugin_list.py
xbmcplugin_logviewer.py
xbmcplugin_update.py

Если что-то не так, чего-то нет - значит криво установился пакет SVN Repo Installer или конфликт с Win7(x64). Попробуйте просто скопировать из WinXp папку XBMC в Win7 . Должно запуститься в portable режиме.

Последний раз редактировалось bigbax; 29.05.2010 в 17:59.
bigbax вне форума   Ответить с цитированием
Старый 29.05.2010, 18:01   #3
Rock82
Member
 
Регистрация: 28.05.2010
Сообщений: 76
По умолчанию

В том и дело что пробывал из XP переносить рабочую версию, я думаю где-то путь может прописать руками надо, но вот где....
Rock82 вне форума   Ответить с цитированием
Старый 29.05.2010, 18:06   #4
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,389
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

При первом запуске XBMC portable он сам пропишет в Application data всё , что считает нужным.
По поводу запуска в portable режиме здесьhttp://wiki.xbmc.org/?title=XBMC_for...rtable_mode.3F

Всё что касается плагинов и прочего ищите здесь C:\Documents and Settings\Ваше имя\Application Data\XBMC\ . Для Win 7 путь будет чуть отличаться

Последний раз редактировалось bigbax; 29.05.2010 в 18:15.
bigbax вне форума   Ответить с цитированием
Старый 29.05.2010, 18:17   #5
Rock82
Member
 
Регистрация: 28.05.2010
Сообщений: 76
По умолчанию

Да есть там всё как вы написали, все файлы на месте в правельных директориях....
Rock82 вне форума   Ответить с цитированием
Старый 30.05.2010, 08:14   #6
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,389
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

Есть идея. Проверьте , установлен ли у Вас в Win7 -- MS Visual C++2008 Sp1 ? По идее Visual C++ должен устанавливаться при инсталляции хбмс. Но у Вас платформа х64 - возможно в этом и есть кривизна установки. Кроме того , не факт, что в этом причина, но нужен NetFramework 2.0-3.5.

Последний раз редактировалось bigbax; 30.05.2010 в 08:45.
bigbax вне форума   Ответить с цитированием
Старый 30.05.2010, 09:34   #7
Rock82
Member
 
Регистрация: 28.05.2010
Сообщений: 76
По умолчанию

MS Visual C++2008 - стоит но не Sp1, да и NetFramework 2.0-3.5 в win 7 по умолчанию присутствуют, их просто надо включать, но у мине они включены, ща MS Visual C++2008 sp1 качну попробую
Rock82 вне форума   Ответить с цитированием
Старый 30.05.2010, 10:11   #8
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,389
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

Всё идёт по кругу. Плохо то , что у меня всё установлено. Надо как-то это всё сломать , а потом экспериментировать наравне с Вами. Не получается . У меня автоматически всё работает.
Здесь описание установки :
http://code.google.com/p/dandar3-xbm...NRepoInstaller

Здесь XBMC_Media_Center_9.11.0.0+Portable.rar
http://portableapps.com/node/19745
http://depositfiles.com/ru/files/u8775ymoy

Последний раз редактировалось bigbax; 30.05.2010 в 19:23.
bigbax вне форума   Ответить с цитированием
Старый 30.05.2010, 18:24   #9
Rock82
Member
 
Регистрация: 28.05.2010
Сообщений: 76
По умолчанию

Ничего не помогает, осталось тока взять комп с нуля и поставить Win 7 x64 и вертеть его, может получу что-нить
Rock82 вне форума   Ответить с цитированием
Старый 30.05.2010, 19:21   #10
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,389
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

Из принципа :
удалил папку xbmc из Document and settings/имя компа/Аpplication data/xbmc
Скачал по этой ссылке http://depositfiles.com/ru/files/u8775ymoy portable версию 54мБ( в архиве есть MS Visual 2008 C++). Запустил XBMC (Portable).exe -всё работает. Не лучший вариант конечно в плане ускорителей, только для проверки по работе с плагинами.
Если и это не помогает , то Win 7 х64 фтопку !

Последний раз редактировалось bigbax; 30.05.2010 в 20:35.
bigbax вне форума   Ответить с цитированием
Ответ
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Текущее время: 18:19. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.