Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Помощь и поддержка > Помощь по плагинам

Ответ
 
Опции темы Опции просмотра
Старый 12.11.2020, 15:09   #961
Jeezz
Junior Member
 
Регистрация: 12.11.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от dvor85 Посмотреть сообщение
У меня вот вопрос: зачем модули requests и pysocks включены в аддон, а не подключены модулями?

PS: Это не претензия, просто для себя хочу понять. У себя удалил их из модуля, прописал зависимости в addon.xml - все работает.
как вариант - это хорошая практика на случай "обновили зависимость, где что-то изменилось без обратной совместимости и теперь аддон не работает вообще, пока не придет разработчик и не исправит"
Jeezz вне форума   Ответить с цитированием
   
Старый 12.11.2020, 15:19   #962
dvor85
Member
 
Регистрация: 10.01.2015
Сообщений: 54
По умолчанию

Цитата:
Сообщение от Jeezz Посмотреть сообщение
как вариант - это хорошая практика на случай "обновили зависимость, где что-то изменилось без обратной совместимости и теперь аддон не работает вообще, пока не придет разработчик и не исправит"
Вообщем то да, но в зависимостях же можно прописать нужную версию (что и сделано с некоторыми зависимостями в этом плагине). Почему включен в сборку только requests тогда?
А может быть обратная ситуация: что то поменялось на ресурсе и поддерживается в последних версиях модулей...
__________________
Torrent-TV PLUS PLUS: http://xbmc.ru/forum/showthread.php?p=76182
dvor85 вне форума   Ответить с цитированием
Старый 12.11.2020, 16:43   #963
Jeezz
Junior Member
 
Регистрация: 12.11.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от dvor85 Посмотреть сообщение
Вообщем то да, но в зависимостях же можно прописать нужную версию (что и сделано с некоторыми зависимостями в этом плагине). Почему включен в сборку только requests тогда?
А может быть обратная ситуация: что то поменялось на ресурсе и поддерживается в последних версиях модулей...
вот тут согласен, зафиксировать - ок, хранить как зависимость - не очень
(хотя вспоминая последние новости с youtube-dl, когда даже из пипа выпилили - может и не самая плохая идея - хранить код as is )
Jeezz вне форума   Ответить с цитированием
Старый 13.11.2020, 15:11   #964
vl.maksime
Senior Member
 
Аватар для vl.maksime
 
Регистрация: 18.10.2015
Адрес: Donetsk, Ukraine
Сообщений: 923
По умолчанию

Зависимость может быть установлена только одной версии. В addon.xml указывается минимальная требуемая, с которой дополнение точно работает. Но если у зависимости выйдет обновление, то она обновится.
__________________
Репозиторий: https://vlmaksime.github.io/repository.vlmaksime/
Поблагодарить: https://vlmaksime.github.io/donate
vl.maksime вне форума   Ответить с цитированием
Старый 26.11.2020, 11:09   #965
KaithlynMoore
Junior Member
 
Регистрация: 26.11.2020
Сообщений: 1
По умолчанию

Цитата:
Сообщение от markhascole Посмотреть сообщение
Buddy Для kodi VPN необходимо, чтобы несколько аддов kodi были распределены по географическим признакам, а во-вторых, если вы являетесь гражданином Великобритании, тогда вам нужно использовать VPN (https://www.reviewsed.com/cyberghost-vs-nordvpn), потому что в Великобритании kodi является полностью нелогичным и без VPN вы можете быть приняты.
Точно, я нахожусь в Великобритании и использую Kodi около 2 лет на avast secureline VPN, и он работает полностью нормально.
KaithlynMoore вне форума   Ответить с цитированием
Старый 30.11.2020, 15:28   #966
RageTester
Member
 
Регистрация: 10.11.2020
Адрес: On the roof of destruction
Сообщений: 30
По умолчанию

Постеры находит, но не одно видео не запускается. Пробовал версию 2.5.1 и 2.5.2, и http и https...
Raspberry 3B+
Через браузер сайт не забаненный...
__________________
RobotRage.pro

Последний раз редактировалось RageTester; 30.11.2020 в 15:37.
RageTester вне форума   Ответить с цитированием
Старый 30.11.2020, 16:27   #967
nickser2006
Member
 
Регистрация: 29.01.2019
Сообщений: 33
По умолчанию

Есть такое на CE сегодня, вчера работало. Все находит, вплоть до качества, но затем крутанет и все
nickser2006 вне форума   Ответить с цитированием
Старый 09.12.2020, 12:51   #968
Jeezz
Junior Member
 
Регистрация: 12.11.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от RageTester Посмотреть сообщение
Постеры находит, но не одно видео не запускается. Пробовал версию 2.5.1 и 2.5.2, и http и https...
Raspberry 3B+
Через браузер сайт не забаненный...
Цитата:
Сообщение от nickser2006 Посмотреть сообщение
Есть такое на CE сегодня, вчера работало. Все находит, вплоть до качества, но затем крутанет и все
я последнее время стал чаще использовать хдрезку, периодически нахожу и улучшаю плагин, если есть проблемы с конкретными фильмами - кидайте в личку, посмотрю

если еще и последние 100 строк лога из kodi.log сможете прикрепить - вообще отлично.
Jeezz вне форума   Ответить с цитированием
Старый 09.12.2020, 20:58   #969
razzor
Senior Member
 
Регистрация: 03.08.2011
Сообщений: 171
По умолчанию

Подскажите, а это только у меня на Kodi 17.3, OpenELEC, RPi 3 выбор разрешения на ступень ниже? (жму 2160p - получаю 1080p...)
razzor вне форума   Ответить с цитированием
Старый 09.12.2020, 21:28   #970
nickser2006
Member
 
Регистрация: 29.01.2019
Сообщений: 33
По умолчанию

Наверное, у всех так CE 9.2.5 Kodi 18.9
nickser2006 вне форума   Ответить с цитированием
Ответ

Метки
музыка, плагин, реквест, яндекс
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Текущее время: 07:09. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.