Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Анонсы, Информация и Общие Темы > Подсказки, описания и FAQ по XBMC

Ответ
 
Опции темы Опции просмотра
Старый 07.10.2020, 14:32   #1
Lapochkin
Junior Member
 
Регистрация: 07.10.2020
Сообщений: 4
По умолчанию Kodi не отображает фильмы

Приветствую всех участников!
Дано: Клиент01: ПК на базе x86, Windows 10 x64, Kodi 18.8; Клиент02: ПК на базе x86, Windows 10 x64, Kodi 18.8; Клиент03: ПК на базе x86, LibreElec.
Ещё 1 комп на Windows 7 x64 с установленным MySQL Server 6.0.
Так же есть NAS с расшаренными по SMB папками с фильмами. Имена фильмов имеют вид "«V» значит Вендетта (2005) (V for Vendetta).avi", т.е. русское название, пробел, год в скобках, пробел, английское название в скобках - все данные взяты с Кинопоиска. Скрапится это все без проблем, Kodi показывает всю информацию о фильме, когда БД настроена локально.
Когда настраиваю хранение базы в SQL - база в нём создаётся, даже разрастается до нескольких мегабайт. При этом позиции просмотра между клиентами синхронизируются, видео, которые просмотрены, отображаются таковыми на всех клиентах.
Папка Thumbnails перенесена в шару на том же НАСе, права на неё полные, при запуске сканирования в папке Thumbnails появляются папка, но общий размер гораздо меньше, чем при локальном хранении.
Ниже листинг файла advancedsettings.xml:
<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>10.10.1.254</host>
<port>3306</port>
<user>root</user>
<pass>123</pass>
</videodatabase>
<pathsubstitution>
<substitute>
<from>special://masterprofile/sources.xml</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/sources.xml</to>
</substitute>
<substitute>
<from>special://masterprofile/mediasources.xml</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/mediasources.xml</to>
</substitute>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>SMB://10.10.1.11/_temp/kodi/userdata/Thumbnails/</to>
</substitute>
</pathsubstitution>
</advancedsettings>

Проблема в том, что Kodi не отображает видео в галерее, там пусто (см. скриншот Screenshot_1.png). Подскажите, что с этим можно поделать, как решить проблему?
Миниатюры
Нажмите на изображение для увеличения
Название: Screenshot_1.png
Просмотров: 31
Размер:	144.5 Кб
ID:	9360  

Последний раз редактировалось Lapochkin; 07.10.2020 в 14:38. Причина: Добавление скриншота
Lapochkin вне форума   Ответить с цитированием
   
Старый 07.10.2020, 15:07   #2
-=Vd=-
Senior Member
 
Аватар для -=Vd=-
 
Регистрация: 14.02.2012
Адрес: Одесса
Сообщений: 1,585
Отправить сообщение для -=Vd=- с помощью Skype™
По умолчанию

Лог скиньте (желательно дебаг режим) от того Коди, в котором не отображаются фильмы.

ЗЫ: Папка Thumbnails у каждого клиента должна быть своя, они не синхронизируемые.
__________________
Media Aggregator (виртуальная медиатека) - http://xbmc.ru/forum/showthread.php?t=10592
Lazy F1 - http://xbmc.ru/forum/showthread.php?t=14300

Последний раз редактировалось -=Vd=-; 07.10.2020 в 15:13.
-=Vd=- на форуме   Ответить с цитированием
Старый 07.10.2020, 15:27   #3
Lapochkin
Junior Member
 
Регистрация: 07.10.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от -=Vd=- Посмотреть сообщение
Лог скиньте (желательно дебаг режим) от того Коди, в котором не отображаются фильмы.

ЗЫ: Папка Thumbnails у каждого клиента должна быть своя, они не синхронизируемые.
Лог во вложении.
В том и дело, что начинаю с первого клиента: запустил, сформировалась локальная БД. Выключил, подсунул xml с настройками, запустил - результат описал - фильмов в галерее нет, как файлы Kodi фильмы видит.
Вложения
Тип файла: 7z kodi.log.7z (5.0 Кб, 33 просмотров)
Lapochkin вне форума   Ответить с цитированием
Старый 07.10.2020, 16:49   #4
-=Vd=-
Senior Member
 
Аватар для -=Vd=-
 
Регистрация: 14.02.2012
Адрес: Одесса
Сообщений: 1,585
Отправить сообщение для -=Vd=- с помощью Skype™
По умолчанию

Цитата:
Сообщение от Lapochkin Посмотреть сообщение
Лог во вложении.
В том и дело, что начинаю с первого клиента: запустил, сформировалась локальная БД. Выключил, подсунул xml с настройками, запустил - результат описал - фильмов в галерее нет, как файлы Kodi фильмы видит.
Зачем формировать локальную БД? Нужно с сразу с MySQL запускать и делать обновление медиатеки.

У вас с 301й строки ошибки доступа к БД.
__________________
Media Aggregator (виртуальная медиатека) - http://xbmc.ru/forum/showthread.php?t=10592
Lazy F1 - http://xbmc.ru/forum/showthread.php?t=14300
-=Vd=- на форуме   Ответить с цитированием
Старый 07.10.2020, 16:55   #5
Lapochkin
Junior Member
 
Регистрация: 07.10.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от -=Vd=- Посмотреть сообщение
Зачем формировать локальную БД? Нужно с сразу с MySQL запускать и делать обновление медиатеки.

У вас с 301й строки ошибки доступа к БД.
Я к тому, что локально БД формируется без проблем...
Да, увидел кучу ошибок в логе. ПодскАжите, с чем связаны ошибки и как устранить?
Lapochkin вне форума   Ответить с цитированием
Старый 07.10.2020, 17:03   #6
-=Vd=-
Senior Member
 
Аватар для -=Vd=-
 
Регистрация: 14.02.2012
Адрес: Одесса
Сообщений: 1,585
Отправить сообщение для -=Vd=- с помощью Skype™
По умолчанию

Цитата:
Сообщение от Lapochkin Посмотреть сообщение
Я к тому, что локально БД формируется без проблем...
Да, увидел кучу ошибок в логе. ПодскАжите, с чем связаны ошибки и как устранить?
Вероятно MySQL недонастроен как следует. Права доступа смотрите. Мне кажется использовать учётную запись root неправильно. Смотрите здесь всё описано.
__________________
Media Aggregator (виртуальная медиатека) - http://xbmc.ru/forum/showthread.php?t=10592
Lazy F1 - http://xbmc.ru/forum/showthread.php?t=14300
-=Vd=- на форуме   Ответить с цитированием
Старый 08.10.2020, 01:09   #7
Lapochkin
Junior Member
 
Регистрация: 07.10.2020
Сообщений: 4
По умолчанию

Цитата:
Сообщение от -=Vd=- Посмотреть сообщение
Вероятно MySQL недонастроен как следует. Права доступа смотрите. Мне кажется использовать учётную запись root неправильно. Смотрите здесь всё описано.
Благодарю автора данного ответа - получилось синхронизировать библиотеки. В ближайшее время подробно изложу, что именно было сделано!
Lapochkin вне форума   Ответить с цитированием
Ответ
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Пропадают фильмы asvitich Подсказки, описания и FAQ по XBMC 2 03.04.2018 10:36
XBMC 13 не отображает надписи меню AxelR8 Поддержка платформы Linux \ Live 3 23.05.2014 21:55
Тормозят фильмы! Aksiden Поддержка платформы Windows 15 21.12.2012 16:53
Не отображает видео на TV nikvs Поддержка платформы Windows 2 15.04.2012 13:30
Не отображает видео на TV nikvs Общие темы для обсуждения 2 15.04.2012 10:07


Текущее время: 14:43. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.