Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Помощь и поддержка > Поддержка платформы Linux \ Live

Ответ
 
Опции темы Опции просмотра
Старый 24.05.2011, 15:05   #1
alex_letz
Junior Member
 
Регистрация: 19.05.2010
Сообщений: 20
По умолчанию Не могу запустить Imon VFD

Имеется корпус Cooler Master CMmedia 260 со встроенным 2х16 Imon VFD и установленной M/B Asus AT5IONT-I. Установил XBMC 10.1 Live. Для настройки пульта и VFD воспользовался http://forum.xbmc.org/showpost.php?p...&postcount=256 . Пульт запустился, а на дисплее отображается LCDproc Server в верхней строке, Cli:0 Scr:0 в нижней строке.
Подскажите, что делаю не так?
P.S. В конце выше приведенного поста сказано: And that's it! Restart your system for luck, and make sure you enable the remote and LCD/VFD in XBMC's settings! В каких настройках XBMC включается дисплей?
alex_letz вне форума   Ответить с цитированием
   
Старый 24.05.2011, 18:16   #2
Demon
Junior Member
 
Регистрация: 28.12.2009
Сообщений: 6
По умолчанию

Нужно отредактировать файл настроек XBMC guisettings.xml как указано в этом сообщении http://xbmc.ru/showpost.php?p=7534&postcount=124
Demon вне форума   Ответить с цитированием
Старый 24.05.2011, 23:10   #3
vallhund
Member
 
Регистрация: 03.04.2010
Адрес: собянинск
Сообщений: 30
По умолчанию

Если точнее, надо в guisettings.xml изменить значение <haslcd>false</haslcd> на <haslcd>true</haslcd>.

Обратите внимание - перед тем, как вносить изменения в этот файл, из XBMC надо выйти.

Дальше проблема будет в том, что русские символы по умолчанию не отображаются, надо сильно шаманить. Но лично мне это и не нужно - от дисплея мне нужен только прогресс-бар во время воспроизведения.
vallhund вне форума   Ответить с цитированием
Старый 25.05.2011, 17:36   #4
alex_letz
Junior Member
 
Регистрация: 19.05.2010
Сообщений: 20
По умолчанию

Спасибо всем откликнувшимся.
Проверял на установленной полной Ubunta 10.10 и XBMC. Индикатор прекрасно работал.
Cейчас установил XBMC 10.1 Live, провел запуск устройств, как написано в указанной выше ссылке. После команды sudo /etc/init.d/LCDd restart постоянно сыпется следующая строка:
lirc_imon: lcd_write: invalid payload size: 32 (expecting 8).
Остановить ничем не могу, после перезагрузки и выходе из XBMC эта строка продолжает сыпаться. Причем пульт в XBMC работает нормально.
Подскажите, что еще не правильно делаю?
alex_letz вне форума   Ответить с цитированием
Старый 25.05.2011, 17:46   #5
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,433
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

ctrl+с не пробовали для прерывания строки?
__________________
Ubuntu 20.0.х, Kodi next
bigbax вне форума   Ответить с цитированием
Старый 25.05.2011, 17:47   #6
alex_letz
Junior Member
 
Регистрация: 19.05.2010
Сообщений: 20
По умолчанию

Пробовал, не помогает. Бежит без остановки.
alex_letz вне форума   Ответить с цитированием
Старый 25.05.2011, 19:30   #7
vallhund
Member
 
Регистрация: 03.04.2010
Адрес: собянинск
Сообщений: 30
По умолчанию

Цитата:
Сообщение от alex_letz Посмотреть сообщение
Пробовал, не помогает. Бежит без остановки.
ЧТобы остановить эти сообщения, надо исхитриться набрать killproc LCDd
(или сразу sudo apt-get remove lcdproc
Для этого надо набирать по одной букве + Enter с последующим нажатием кнопки курсора вверх (повтор команды).

У меня было тоже самое.
Не знаю как, но проблема решилась после полного сноса lirc и lcdproc с последующей установкой заново. Не помню конкретные телодвижения с настройками, но...

Попробуйте:
1. Снести Lirc и lcdproc (sudo apt-get remove lirc, sudo apt-get remove lcdproc)
2. Установить lirc (sudo apt-get install lirc)
3. При установке выбрать iMon Pad
4. Перезагрузиться, проверить (XBMC) пульт
5. Установить lcdproc (sudo apt-get install lcdproc)
6. В файле etc/modprobe.d/00-system.conf должна быть строчка
options lirc_imon display_type=1
7. Перезагружаемся
8. ?????
9. PROFIT!!!!

Отпишитесь, если что, будем восстанавливать события.
vallhund вне форума   Ответить с цитированием
Старый 25.05.2011, 21:30   #8
alex_letz
Junior Member
 
Регистрация: 19.05.2010
Сообщений: 20
По умолчанию

Спасибо!
Завтра попробую и отпишусь, просто все железо находится пока на работе (там времени больше для ковыряний )
alex_letz вне форума   Ответить с цитированием
Старый 25.05.2011, 22:30   #9
Vanek
Senior Member
 
Регистрация: 03.07.2010
Сообщений: 390
Отправить сообщение для Vanek с помощью Skype™
По умолчанию

Цитата:
Сообщение от vallhund Посмотреть сообщение
надо исхитриться набрать killproc LCDd
(или сразу sudo apt-get remove lcdproc
Для этого надо набирать по одной букве + Enter с последующим нажатием кнопки курсора вверх (повтор команды)
можно и без подобных ухищрений - при загрузке удерживать Shift, выбрать безопасный режим

какая там версия ядра? такая ъерня была на 2.6.32. Я так понимаю XBMC 10.1 Live - это та же Ubuntu 10.04 как раз с таким ядром - после установки >=2.6.35 проблема исчезла - новые переработанные драйвера уже встроены в ядро
такшто самый лучший вариант - вернуть 10.10 добавить ppa xbmc и поставить пакет xbmc-live
Цитата:
Сообщение от alex_letz Посмотреть сообщение
на работе (там времени больше для ковыряний )
абалдеть


ЗЫ Насчёт кириллических литер - можно пересобрать xbmc с вариантом файла из моей подписи, или этот вариант, но как по мне, он посложнее...
Vanek вне форума   Ответить с цитированием
Старый 26.05.2011, 18:35   #10
alex_letz
Junior Member
 
Регистрация: 19.05.2010
Сообщений: 20
По умолчанию

Для начала скажу, что в линуксе я не силен. Поэтому некоторые ваши ответы перевариваю до сих пор.
Набрать команды в бегущих строках не удалось, так как они слишком быстро бежали по экрану. Войти через Shift при загрузке в безопасный режим не получилось, а после выхода с Shiftом из XBMC попал в пустой черный экран. Выйти оттуда смог только ресетом. Машина загрузилась, и случилось чудо, строки перестали бежать. Отредактировал файл guisettings.xml и перезагрузил, индикатор заработал. Причина исчезновения бегущих строк осталась загадкой.

Цитата:
Сообщение от Vanek Посмотреть сообщение
какая там версия ядра? такая ъерня была на 2.6.32. Я так понимаю XBMC 10.1 Live - это та же Ubuntu 10.04 как раз с таким ядром - после установки >=2.6.35 проблема исчезла - новые переработанные драйвера уже встроены в ядро
такшто самый лучший вариант - вернуть 10.10 добавить ppa xbmc и поставить пакет xbmc-live
А как ядро поменять в XBMC-live, или имеется ввиду установка полной убунты 10.10 с XBMC-live?

Цитата:
Сообщение от Vanek Посмотреть сообщение
ЗЫ Насчёт кириллических литер - можно пересобрать xbmc с вариантом файла из моей подписи, или этот вариант, но как по мне, он посложнее...
Можно подсказать подробнее о пересборке с использованием файла LCD.cpp или для новичка это слишком сложно?
alex_letz вне форума   Ответить с цитированием
Ответ

Метки
imon
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
[Live] Пульт iMON с корпусом GMC Nooblesse AV AVC-S1 jogan Поддержка платформы Linux \ Live 60 13.03.2012 09:02
iMON c Touchscreen tit1971 Поддержка платформы Linux \ Live 5 04.01.2011 10:07
Помогите пожалуйста нубу с iMon MasterJ Поддержка платформы Windows 15 16.11.2010 12:05
Ресивер iMon, MCE, Lirc помогите завести. TheKIP Поддержка платформы Linux \ Live 1 27.09.2010 22:04


Текущее время: 12:44. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.