Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Помощь и поддержка > Поддержка платформы Linux \ Live

Ответ
 
Опции темы Опции просмотра
Старый 03.07.2010, 10:24   #1
SokolovSV
Junior Member
 
Регистрация: 03.07.2010
Сообщений: 3
По умолчанию ошибка при установке

помогите плз нубу в *nix-ах

решил изобразить HTPC
за основу взята Ubuntu 10.04

пробую ставить:
sudo apt-get install xbmc xbmc-data xbmc-live xbmc-skin-confluence xbmc-standalone

Чтение списков пакетов...
Построение дерева зависимостей...
Чтение информации о состоянии...
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
xbmc-bin: Зависит: libcdio7 но он не может быть установлен
Зависит: libfaad0 (>= 2.6.1) но он не может быть установлен
Зависит: libmysqlclient15off (>= 5.0.27-1) но он не может быть установлен
E: Сломаные пакеты

что такое и как с этим бороться?
на сколько я понимаю, дистриб хочет более старые библиотеки?
SokolovSV вне форума   Ответить с цитированием
   
Старый 03.07.2010, 10:54   #2
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,403
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

не ставьте текущие svn версии, если хотите с хбмс работать полноценно. Повтроряться не стоит http://xbmc.ru/showpost.php?p=2429&postcount=31
Можно скачать xbcmfreak-10.08-svn31495-lucid http://xbmcfreak.binkey.nl/xbcmfreak...495-lucid1.zip --- и вот Вам готовая установка с mini Ubuntu 10.04 +xbмс-10.08-svn31495-lucid1. А потом вопросами забросаете. Но HD видео svn31495 воспроизводит на ура! Да и следующую 31552 ставил - тоже всё ОК кроме работы с пультом и терминалом.

И когда ставите? то смотрите на состояние пакетов установки . На сегодня i386 xbmc_10.08~svn31555-lucid1 не активированы для установки https://edge.launchpad.net/~team-xbm...s_filter=lucid
-----------------------------------------------------
Официальная версия с svn 26018lucid --https://launchpad.net/~team-xbmc/+archive/ppa
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 91E7EE5E
Для установки хбмс достаточно вводить
sudo apt-get update --- происходит обновление данных о состоянии репо
sudo apt-get upgrade --- подготавливается информация о доступных обновлениях и предложение об установке доступных пакетов. И это необязательно будет хбмс. Могут быть включены библиотеки разного рода и т.д. Сначала внимательно читаем , что там есть , а потом жмём "Y" илим "N".
sudo apt-get install xbmc ( можно добавить xbmc-standalone) --- если таковые обновления хбмс имеются и не идут вразрез с установленным дистрибутивом
Если поставили полную 10.04 , то ещё проще : Приложения -Центр приложений-в окно поиска XBMC - и если репо добавлены в source .list , то вылезут доступные для установки пакеты. Будет предложено установка XBMC (Full metapackage) и ниже список включённых пакетов доступных для установки.
p.s. обратите внимание на сообщение терминала
"Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming."
Это может означать , что Вы ставили скажем официальную версию , а обновиться хотите из svn repo. Значит сначала надо удалить предыдущую версию и потом ставить svn. Или в текущей ,выложенной версии данные пакеты просто отсутствуют . SVN в основном для тестеров хбмс. Надо уже создать тему про этот вопрос что-то вроде "Обновление хбмс из SVN". Много вариантов хбмс. Читайте здесь:
http://xbmc.ru/showthread.php?p=2470#post2470
__________________
Kodi 18

Последний раз редактировалось bigbax; 03.07.2010 в 13:53.
bigbax вне форума   Ответить с цитированием
Старый 03.07.2010, 14:36   #3
SokolovSV
Junior Member
 
Регистрация: 03.07.2010
Сообщений: 3
По умолчанию не все так просто

во первых выражаю признательность за столь подробный ответ.

во вторых - не все так просто, через центр приложений напарываюсь опять на зависимости:




(все возможные обновления установлены)

PS. установка убунты прошла гладко, ни чего с ней больше не делал

Последний раз редактировалось SokolovSV; 03.07.2010 в 14:58.
SokolovSV вне форума   Ответить с цитированием
Старый 03.07.2010, 16:10   #4
bigbax
Senior Member
 
Аватар для bigbax
 
Регистрация: 12.12.2009
Адрес: Моск.обл.
Сообщений: 4,403
Отправить сообщение для bigbax с помощью ICQ
По умолчанию

Зависимости , которые не удовлетворены - это удаление всех пакетов предыдущей установки или....
Так вот, что я вижу у Вас сейчас готов к установке XBMC (Full metapackage) -- только вот откуда?! Из репо Ubuntu Jaunty 9.04!
Но у Вас установлена не Ubuntu Jaunty 9.04 , а Ubuntu lucid 10.04 !
К сожалению скрины не отдельно, но в правом нижнем углу видно , что Вы пытаетесь на 10.04 lucid установить пакеты Jaunty .
Удалите их в sources.list
sudo nano /etc/apt/sources.list -- все ссылки заканчивающиеся на /ubuntu jaunty main
или в
Система -Администрирование - Источники приложений. Удалите ссылки заканчивающиеся на /ubuntu jaunty main -скорее всего там они не прописаны, но это самый простой для Вас метод.

в терминале введите
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 91E7EE5E 64234534
дождитесь получения сообщения типа import 2 gpg keys
тем самым получите доступ к серверу обновлений SVN и официальной сборок

Нажмите в Источниках приложений кнопку "Добавить" и в окошке поочередно введите что-то одно
или для получения официальной версии хбмс
deb http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/team-xbmc/ppa/ubuntu lucid main
Это будет нормально работающая сборка, с мизером глюка , которого Вы сначала и не заметите
------
или для тестирования очередных некорректно работающих svn сборок :
deb http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu lucid main
deb-src http://ppa.launchpad.net/team-xbmc-svn/ppa/ubuntu lucid main
В новых svn меня порадовало корректное определение кодека к моим тестовым фильмам mts, ts, mkv 720/1080p. И минусом явилось отсутсвие поддержки для политик управления (менеджмента). Так что если Вас это не напрягает, а хотите смотреть видео HD качества -ставьте svn. В остальном будет много вопросов.

после этого в терминале
sudo apt-get update
sudo apt-get install xbmc
Будут установлены пакеты имеющиеся в указанном Вами репо.
Или гоу в Центр приложений ставить хбмс (Full metapackage).
Подробно с картинками здесь http://xbmc.ru/showthread.php?t=343
__________________
Kodi 18

Последний раз редактировалось bigbax; 03.07.2010 в 18:05.
bigbax вне форума   Ответить с цитированием
Старый 04.07.2010, 12:58   #5
SokolovSV
Junior Member
 
Регистрация: 03.07.2010
Сообщений: 3
По умолчанию

bigbax
огромное спасибо! все получилось, установил
а консультация - подробная и по существу, респект!

буду дальше копаться и пробовать
SokolovSV вне форума   Ответить с цитированием
Ответ
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Текущее время: 10:39. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.