Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины.
   

Вернуться   Форум XBMC и Kodi. Помощь, поддержка, обсуждение, плагины. > Помощь и поддержка > Помощь по плагинам

Ответ
 
Опции темы Опции просмотра
Старый 10.12.2015, 22:15   #171
rauf27
Junior Member
 
Регистрация: 10.03.2012
Сообщений: 26
По умолчанию

Цитата:
Сообщение от Const86 Посмотреть сообщение
Нет. Не будет. Исходники открыты, можете если что самостоятельно это сделать. Там 2 строчки подправить.

P.S. Брался как-то писать pvr-клиент на питоне. Но потом потерял, интерес к ТТВ целиком. Если кто захочет, можно взяться за него вместе
Здравстуйте,
на соседнем форуме, Вы упомянули, что для того чтобы пвр плагин работал с бесплатной (финальной) версией п2прокси, Вы должны его исправить. Немог ли бы вы подсказать, что в нужно исправить в исходниках ?

Заранее благодарен.
rauf27 вне форума   Ответить с цитированием
   
Старый 11.12.2015, 15:50   #172
Const86
Senior Member
 
Регистрация: 24.12.2012
Сообщений: 1,175
По умолчанию

Нужно изменить значения констант:
XBMC_PVR_API_VERSION
XBMC_PVR_MIN_API_VERSION
XBMC_GUI_API_VERSION
XBMC_GUI_MIN_API_VERSION
Или заменить их нужными значениями.
А самым правильным способом было бы обновить библиотеки:
libXBMC_addon.h
libXBMC_pvr.h
libXBMC_gui.h
Взять их можно из последней версии IPTV-Simple
Const86 вне форума   Ответить с цитированием
Старый 11.12.2015, 16:47   #173
meksis
Senior Member
 
Аватар для meksis
 
Регистрация: 07.05.2013
Адрес: Орел
Сообщений: 115
По умолчанию

Цитата:
Сообщение от Const86 Посмотреть сообщение
Нужно изменить значения констант:
XBMC_PVR_API_VERSION
XBMC_PVR_MIN_API_VERSION
XBMC_GUI_API_VERSION
XBMC_GUI_MIN_API_VERSION
Или заменить их нужными значениями.
А самым правильным способом было бы обновить библиотеки:
libXBMC_addon.h
libXBMC_pvr.h
libXBMC_gui.h
Взять их можно из последней версии IPTV-Simple
Кто-нибудь сможет это сделать? Интересует работа PVR плагина только на Linux.
PS: за мной не заржавеет. Спасибо.
__________________
«NVIDIA Shield Android TV Nougat» - NVIDIA® Tegra® X1 - «SPMC 16.7-02»
meksis вне форума   Ответить с цитированием
Старый 11.12.2015, 18:41   #174
rauf27
Junior Member
 
Регистрация: 10.03.2012
Сообщений: 26
По умолчанию

Цитата:
Сообщение от Const86 Посмотреть сообщение
Нужно изменить значения констант:
XBMC_PVR_API_VERSION
XBMC_PVR_MIN_API_VERSION
XBMC_GUI_API_VERSION
XBMC_GUI_MIN_API_VERSION
Или заменить их нужными значениями.
А самым правильным способом было бы обновить библиотеки:
libXBMC_addon.h
libXBMC_pvr.h
libXBMC_gui.h
Взять их можно из последней версии IPTV-Simple
Можете ткнуть меня носом в последнюю версию ? Все что я нашел https://github.com/afedchin/xbmc-addon-iptvsimple в этом репо. Но там все старое.

https://github.com/kodi-pvr/pvr.iptvsimple кажется это последняя сборка. Но там вышеперечисленных файлов нет, видимо потому, что процесс сборки поменяли.

Последний раз редактировалось rauf27; 11.12.2015 в 18:49.
rauf27 вне форума   Ответить с цитированием
Старый 12.12.2015, 19:35   #175
Const86
Senior Member
 
Регистрация: 24.12.2012
Сообщений: 1,175
По умолчанию

Ну в таком случае их следует взять из исходников Kodi. Вообще это они не хорошо сделали, что исходники теперь напрямую связаны с исходниками Kodi. Теперь, что бы скомпилировать этот плагин приходится тянуть с сабой полные исходные коды и самого Kodi...

UPD.
Возможно эти подойдут:
Раз https://github.com/const586/xbmc/blo...mc_pvr_types.h
https://github.com/afedchin/xbmc-add.../libXBMC_gui.h

Последний раз редактировалось Const86; 12.12.2015 в 19:44.
Const86 вне форума   Ответить с цитированием
Ответ
 


Здесь присутствуют: 1 (пользователей: 0 , гостей: 1)
 
Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Текущее время: 10:52. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.